امتیاز موضوع:
  • 188 رای - 1.9 میانگین
  • 1
  • 2
  • 3
  • 4
  • 5
اموزش جامع ccna
#21
خوب حالا میخواهیم اطلاعاتی در مورد پروتکل rip بدیم و روش استفاده کردنش در شبکه

توضیحات :

پروتكل RIP
RIP ( برگرفته شده از Routing Information Protocol ) به معنی واقعی يك پروتكل distance-vector است . پروتكل فوق در هر 30 ثانيه تمام اطلاعات موجود در جدول روتينگ را برای تمامی اينترفيس های فعال ارسال می نمايد . RIP صرفا" از تعداد hop برای تعيين بهترين مسير به شبكه راه دور استفاده می نمايد .حداكثر تعداد hop می تواند عدد 15 را داشته باشد و نسبت دهی عددی بالاتر از 15 به منزله غيرقابل دسترس بودن شبكه است.
RIP در شبكه های كوچك به خوبی كار می كند ولی برای شبكه های بزرگ كه دارای لينك های ارتباطی WAN ( برگرفته شده از wide area network ) كند و تعداد بسيار زيادی روتر هستند مناسب نمی باشد .
در نسخه شماره يك RIP صرفا" از روتينگ classful استفاده می گردد . اين بدان معنی است كه تمامی دستگاه های موجود در شبكه می بايست از subnet mask مشابهی استفاده نمايند . محدوديت فوق به دليل ماهيت ارسال اطلاعات بهنگام می باشد. در نسخه شماره يك RIP ، اطلاعات بهنگام ارسالی شامل اطلاعات subnet mask نمی باشند .
در RIP نسخه دو ، ويژگی جديدی به نام روتينگ Prefix ارائه شده است كه به كمك آن امكان ارسال اطلاعات subnet mask به همراه مسيرهای بهنگام شده فراهم می گردد . به اين نوع روتينگ ، اصطلاحا" روتينگ classless گفته می شود .

RIP از سه نوع تايمر مختلف برای تنظيم كارآئی خود استفاده می نمايد .
  • Route update timer ، فاصله زمانی ارسال يك نسخه كامل از اطلاعات بهنگام روتينگ را مشخص می نمايد . در بازه زمانی فوق ، روتر يك نسخه كامل از اطلاعات موجود در جدول روتينگ خود را برای تمامی همسايگان ارسال می نمايد . اين زمان معمولا" 30 ثانيه در نظر گرفته می شود .
  • Route invalid timer ، مدت زمانی را مشخص می نمايد كه پس از سپری شدن آن ، روتر به اين نتيجه خواهيد رسيد كه يك مسير غيرمعتبر است . اين زمان معمولا" 180 ثانيه در نظر گرفته می شود و اگر يك روتر در بازه زمانی فوق هيچگونه اطلاعات جديدی را در خصوص يك مسير خاص دريافت ننمايد ، آن مسير را غيرمعتبر می نمايد . در صورت تحقق چنين شرايطی ، روتر اقدام به ارسال اطلاعات بهنگام برای تمامی همسايگان خود می نمايد تا به آنها بگويد كه مسير غيرمعتبر است .
  • Route flush timer ، مدت زمان بين غيرمعتبر اعلام شدن يك مسير و حذف آن از جدول روتينگ را مشخص می نمايد . اين زمان معمولا" 240 ثانيه در نظر گرفته می شود . قبل از اين كه يك مسير از جدول روتينگ حذف گردد ، روتر اين موضوع را به اطلاع همسايگان خود می رساند . مقدار Route invalid timer می بايست كمتر از route flush timer باشد تا روتر زمان كافی جهت اطلاع به همسايگان خود را قبل از بهنگام سازی جدول در اختيار داشته باشد .
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#22
خوب در شبکه قبلی با دستور ip rout که اشنا شدید.

دستور router rip خیلی اسون تره

پروتکل router rip

توی شبکه قبل 3 تا روتر داشتیم

حالا واسه ارتباط شبکه و روترها باید getway شبکه رو بهش معرفی کنید.

در روتر میانی با دستور ساده زیر شبکه معرفی میکنیم به روتر :

کد:
enable
config t
router rip
network 192.168.20.0
network 192.168.30.0


با این دستور روتر سمت راست و چپ رو بهش معرفی کردیم .

روتر سمت راست :

کد:
enable
config t
router rip
network 192.168.30.0
network 192.168.40.0


و روتر سمت چپ :

کد:
enable
config t
router rip
network 192.168.10.0
network 192.168.20.0


این عکس هم بصورت تصویری پیوست کردم که راحت تر متوجه بشید :



گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#23
پروتکل EIGRP رو میخوام توضیح بدم اطلاعات از سایت SRCO میزارم بعد خودم روش استفاده کردنش رو میگم

پروتكل EIGRP دارای‌ مجموعه پتانسيل هائی است كه آنرا با ساير پروتكل های روتينگ نظير IGRP كاملا" متمايز می نمايد . برخی از اين ويژگی ها عبارتند از :
  • حمايت از IP ، IPX و AppelTalk از طريق PDM ( برگرفته شده از Protocol-Dependent Modules )
  • تشخيص كارآمد همسايگان
  • ارتباط از طريق RTP ( برگرفته شده از Reliable Transport Protocol )
  • انتخاب بهترين مسير از طريق DUAL (برگرفته شده از diffusing update algorithm )
  • حمايت از چندين سيستم خودمختار ( AS )
  • حمايت از خلاصه سازی و VLSM ( برگرفته شده از Variable Length Subnet Masking )
    در ادامه به بررسی هر يك از ويژگی های فوق خواهيم پرداخت .
    ماژول های وابسته به پروتكل (Protocol-Dependent Modules)
    يكی از ويژگی های جالب پروتكل EIGRP ، حمايت آن از روتينگ چندين پروتكل لايه شبكه نظير IPX ، IP و AppelTalk است . پروتكل IS-IS ( برگرفته شده از Intermediate System-to-Intermediate System ) تنها پروتكل روتينگ نزديك به پروتكل EIGRP است كه از چندين پروتكل لايه شبكه حمايت می نمايد . با اين تفاوت كه پروتكل فوق صرفا" از IP و CLNS ( برگرفته شده از Connectionless Network Service) حمايت می نمايد .
    EIGRP با بكارگيری پتانسيلی با نام PDM ( برگرفته شده از protocol-dependent modules ) از پروتكل های مختلف لايه شبكه حمايت می نمايد . هر PDM پروتكل EIGRP ، مجموعه ای جداگانه از جداول حاوی اطلاعات روتينگ را نگهداری می نمايد كه در ارتباط با يك پروتكل خاص بكارگرفته می شوند . اين بدان معنی است كه EIGRP برای هر يك از پروتكل ها يك جدول جداگانه را نگهداری می نمايد ( نظير جداول IP/EIGRP ، IPX/EIGRP و AppelTalk/EIGRP ) .
    تشخيص همسايگان
    قبل از اين كه روترهای EIGRP تصميم به مبادله مسيرها با يكديگر نمايند ، می بايست همسايگان خود را شناسائی نمايند . برای ايجاد رابطه همسايگی می بايست شرايط زير وجود داشته باشد :
    • دريافت Hello و يا ACK ( برگرفته شده از acknowledgment )
    • تطبيق شماره سيستم خودمختار (AS)
    • متريك يكسان
      پروتكل های Link-state علاقه مند به استفاده از پيام های Hello برای ايجاد رابطه همسايگی می باشند چراكه آنها معمولا" اقدام به ارسال اطلاعات بهنگام مسيرها بطور ادواری نمی نمايند و می بايست با بكارگيری مكانيزم هائی خاص قادر به تشخيص همسايگان خود بطور پويا ( تشخيص يك همسايه جديد و يا خروج از ليست همسايگان ) باشند . برای برقراری رابطه همسايگی ، روترهای EIGRP می بايست بطور پيوسته پيام هائی موسوم به Hello را از همسايگان خود دريافت نمايند .
      روترهای EIGRP كه به نواحی خودمختار (AS ) مختلفی وابسته می باشند بطور اتوماتيك اطلاعات روتينگ را بين خود به اشتراك نمی گذارند و به عنوان همسايه تلقی نمی گردند . سياست فوق مزايای متعددی را به دنبال خواهد داشت ( خصوصا" زمانی كه از پروتكل EIGRP در شبكه های بزرگ استفاده می گردد ) . در چنين مواردی ، حجم اطلاعات روتينگ منتشر شده در بين يك ناحيه خود مختار خاص كاهش پيدا می نمايد . تنها نكته قابل تامل در اين رابطه ، لزوم توزيع مجدد بين نواحی خود مختار بطور دستی است .
      زمانی كه EIGRP يك همسايه جديد را تشخيص می دهد و قصد ايجاد يك رابطه همسايگی با آن را از طريق مبادله پيام های Hello دارد ، تمامی اطلاعات روتينگ خود را در اختيار آن قرار می دهد ( تنها حالتی كه تمامی اطلاعات جدول روتينگ ارسال می گردد ) . زمانی كه اين اتفاق می افتد ، هر يك از آنها تمامی جداول روتينگ خود را برای ديگری منتشر می نمايد . پس از اين كه هر يك از آنها از مسيرهای همسايه خود آگاهی يافت ، صرفا" تغييرات در جدول روتينگ بين آنها مبادله می گردد .
      زمانی كه روترهای EIGRP اطلاعات بهنگام را از همسايگان خود دريافت می نمايند ، آنها را در يك جدول توپولوژی محلی ذخيره می نمايند . اين جدول حاوی تمامی مسيرهای شناخته شده از تمامی همسايگان شناخته شده است و از آن به عنوان مواد خام انتخاب بهترين مسير و استقرار آن در جدول روتينگ استفاده می گردد .
      ارتباط از طريق RTP
      EIGRP از يك پروتكل اختصاصی با نام RTP ( برگرفته شده از Reliable Transport Protocol ) به منظور مديريت مبادله پيام بين روترهائی كه بر اساس EIGRP با يكديگر گفتگو می كنند ، استفاده می نمايد .
      يكی از ويژگی های مهم پروتكل RTP ، قابليت اطمينان به آن است . شركت سيسكو مكانيزمی را طراحی نموده است كه به كمك آن بتواند پيام های multicast و unicast بهنگام سازی را با سرعت توزيع و وضعيت دريافت داده توسط گيرنده را پيگيری نمايد .
      زمانی كه EIGRP ترافيك multicast را ارسال می نمايد از آدرس 0 . 0. 0 . 224 كلاس D استفاده می نمايد . همانگونه كه اشاره گرديد هر روتر EIGRP نسبت به همسايگان خود آگاهی داشته و برای هر پيام multicast كه ارسال می نمايد ، ليستی از همسايگان را كه به آن پاسخ می دهند نگهداری می نمايد . در صورتی كه EIGRP پاسخی را از يك همسايه دريافت نكند ، در تلاشی مجدد برای آن يك پيام unicast را ارسال می نمايد . در صورتی كه پس از 16 مرتبه تلاش پاسخی از همسايه دريافت نگردد ، اين فرضيه به اثبات می رسد كه همسايه از بين رفته است . به فرآيند فوق reliable multicast گفته می شود .
      روترها برای رهگيری اطلاعات ارسالی خود به آنها يك شماره ترتيب را نسبت می دهند . با استفاده از روش فوق ، امكان تشخيص اطلاعات قديمی ، تكراری و يا خارج از ترتيب فراهم می گردد .
      قابليت انجام اين گونه عمليات بسيار حائز اهميت است چراكه EIGRP يك پروتكل آرام است كه در زمان راه اندازی، بانك های اطلاعاتی روتينگ خود را با همسايگان مبادله و در ادامه و به منظور حفظ سازگاری بانك اطلاعاتی در طول زمان ، صرفا" اقدام به مبادله تغييرات می نمايد . از دست دادن دائمی هر گونه بسته اطلاعاتی و يا پردازش بر روی بسته های اطلاعاتی بيهوده می تواند خرابی بانك اطلاعاتی روتينگ را به دنبال داشته باشد .
      استفاده از الگوريتم DUAL برای انتخاب بهترين مسير
      EIGRP از الگوريتم DUAL (برگرفته شده از diffusing update algorithm ) برای انتخاب و نگهداری بهترين مسير به هر شبكه راه دور استفاده می نمايد . الگوريتم فوق دارای ويژگی های زير است :
      • backup از مسيرها
      • حمايت از VLSMs
      • بازيافت پويای مسير
      • درخواست از همسايگان برای گزينش مسيرهای ناشناخته ديگر
      • ارسال درخواست برای يك مسير جايگزين در صورت عدم يافتن مسير
        EIGRP با بكارگيری الگوريتم DUAL توانسته است سريعترين زمان همگرائی در بين ساير پروتكل های روتينگ را دارا باشد . سرعت همگرائی بالای EIGRP به دو عامل اساسی زير بستگی دارد:
        • عامل اول : روترهای EIGRP يك نسخه از تمامی مسيرهای همسايگان خود را نگهداری می نمايند تا بتوانند از آن برای محاسبه cost هر شبكه راه دور استفاده نمايند . در صورت بروز مشكل برای بهترين مسير ،محتويات جدول توپولوژی به منظور انتخاب بهترين مسير جايگرين بررسی می گردد .
        • عامل دوم : در صورتی كه يك مسير جايگزين مناسب در جدول محلی توپولوژی وجود نداشته باشد ، روترهای EIGRP به سرعت از همسايگان خود برای يافتن يك مسير مناسب درخواست كمك می نمايند .
          همانگونه كه اشاره گرديد ، ايده ارسال پيام های Hello ، تشخيص سريع همسايگان جديد و همسايگانی خارج شده از ليست همسايگان است .
          RTP ، مكانيزمی مطمئن برای حمل پيام ها را ارائه می نمايد و DUAL با استناد به مكانيزم فوق ، مسئوليت انتخاب و نگهداری اطلاعات در رابطه با بهترين مسيرها را برعهده دارد .
          چندين ناحيه خودمختار
          EIGRP از شماره نواحی خود مختار ( ASNs ) برای شناسائی مجموعه ای از روترهائی كه اطلاعات روتينگ را بين خود به اشتراك می گذارند ، استفاده می نمايد . صرفا" روترهائی كه دارای ASN ( برگرفته شده از autonomous system numbers ) مشابه می باشند ، مسيرها را به اشتراك می گذارند . با استفاده از رويكرد فوق در شبكه های بزرگ ، به معظل جداول مسير و توپولوژی پيچيده كه كاهش سرعت همگرائی شبكه را به دنبال خواهد داشت، خاتمه داده می شود .
          با تقسيم شبكه به چندين ناحيه خودمختار جداگانه EIGRP ، درصد بسيار زيادی از تبعات منفی مديريت و نگهداری يك شبكه بزرگ كاهش می يابد. هر ناحيه خود مختار شامل مجموعه ای از روترهای همجوار است كه اطلاعات مسيرها را بين خود به اشتراك گذاشته و با توزيع مجدد آنها زمنيه استفاده از اطلاعات فوق بين نواحی خودمختار جداگانه نيز فراهم می گردد .
          استفاده از توزيع مجدد در EIGRP ، بيانگر يك ويژگی جالب ديگر از اين پروتكل است . معمولا" AD ( برگرفته شده از administrative distance ) مسيرهای EIGRP معادل 90 در نظر گرفته می شود . اين موضوع صرفا" برای مسيرهائی كه از آنها به عنوان مسيرهای داخلی EIGRP نام برده می شود صادق می باشد . اين گونه مسيرها ، مسيرهائی هستند كه از درون يك ناحيه خودمختار خاص و توسط روترهای EIGRP كه جملگی عضو يك سيستم خود مختار مشابه می باشند، سرچشمه می گيرند .
          مسيرهای خارجی EIGRP ، نوع ديگری از مسيرها می باشند كه دارای AD معادل 170 می باشند كه خيلی هم خوب نيست . اين گونه مسيرها ، در جداول مسير EIGRP بطور دستی و يا توزيع مجدد اتوماتيك قرار می گيرند و شبكه هائی را مشخص می نمايند كه در خارج از سيستم خود مختار EIGRP می باشند .

          حمايت از VLSMs و خلاصه سازی
          EIGRP به عنوان يكی از پروتكل های روتينگ classless ، از VLSMs حمايت می نمايد . حمايت از ويژگی VLSM بسيار حائز اهميت است چراكه با استفاده از پتانسيل فوق امكان نگهداری فضای آدرس دهی از طريق subnet mask فراهم می گردد ( نظير استفاده از 30 بيت subnet mask برای شبكه های point-to-point ) .
          با توجه به اين كه subnet mask به همراه هر مسير بهنگام نيز ارسال می گردد ، اين امكان برای پروتكل EIGRP فراهم می گردد كه از زير شبكه های ناپيوسته نيز حمايت نمايد . بدين ترتيب ، طراحان شبكه های كامپيوتری در زمان طراحی يك شبكه IP دارای انعطاف بيشتری می باشند .
          يك شبكه ناپيوسته دارای دو شبكه classful است كه از طريق يك شبكه با كلاس متفاوت به يكديگر متصل شده اند . شكل 1 ، يك شبكه ناپيوسته را نشان می دهد .

          شكل 1 : شبكه ناپيوسته
          در شكل فوق دو زير شبكه به آدرس های 0 . 10 . 16 . 172 و 0 . 20 . 16 . 172 از طريق يك شبكه 0 . 1 . 3 . 10 به يكديگر متصل شده اند . هر روتر اين گونه فكر می كند كه دارای تمامی شبكه كلاس B با آدرس 0 . 0. 16 . 172 و به صورت پيش فرض است .
          EIGRP ، همچنين از ايجاد دستی خلاصه ها بر روی هر روتر EIGRP حمايت می نمايد . اين كار كاهش اندازه جدول مسير را به دنبال خواهد داشت . EIGRP ، بطور اتوماتيك شبكه ها را در محدوده های classful مربوطه خلاصه می نمايد .
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#24
خوب حالا میخواهیم نحوه کانفیگ کردن پروتکل EIGRP اموزش بدم.

دقیقا مثل پست قبلی INTERFACE ها رو وارد کنید .

حالا برای استفاده در روتر دستور زیر رو تایپ کنید.

کد:
ENABLE
CONFIG T
Router EIGRP 1

اطلاعات بیشتر در مورد دستور ROUTER EIGRP 1 :

اون عدد 1 که بعد از EIGRP امده به AS یا همون Autonomous System معروفه. یک AS درواقع یک منطقه هست که توسط یک پروتکل خاص مسیر یابی میشه و توسط یک سازمان کنترل میشه. به این معنی که ما برای اینکه روتر هامون بتونن با هم ارتباط همسایگی تشکیل بدن توسط EIGRP ، باید همه درون یک AS قرار داشته باشند و این عدد برای همه باید یکسان باشه

در واقع 1 در اینجا حوضه رو مشخص میکنه فقط باید اینو یکسان تعریف کنید.

حالا فقط کافیه net شبکه رو معرفی کنید.

به این صورت به فرض :

کد:
network 192.168.10.0 0.0.0.255


حالا شاید براتون سوال باشه این

کد:
0.0.0.255


چیه ؟

در واقع همان subnetmask هست که معکوسش کردم معکوسش میشه 0.0.0.255 که بهش میگن wildCardMask

کد:
SubnetMask : 255.255.255.0 ==== wildcardMask : 0.0.0.255


گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#25



مسيريابی در اينترنت جزء اکثر مواردی است که رغبت بدان همچنان تنزل نيافته است و برای داشتن الگوريتم مسيريابی بهينه بايد ميزان مطلوبيت و ميزان بهينگی را مورد توجه قرار دهيم ومنظور از آن اثبات بهبود سطح سرويس کاربران به منظور پشتيبانی از نيازمنديهای چند رسانه ای در دنيای امروز اينترنت است.

الگوريتم های مسيريابی را می توان به دو دسته سراسری متمرکز که اطلاعات کامل از زيرساخت شبکه دارد(LS) ونيز دسته غير متمرکز که اطلاعات کاملی ندارد و فقط از همسايگان خود مطلع است(DV) تقسيم بندی کرد.پروتکلOSPF در دسته LS قرار دارد و از الگوريتم Dijkstra برای مسيريابی استفاده می کند.

پروتکل های فعلی مسيريابی در اينترنت ازقبيل OSPF و RIP و BGP پروتکل های مسيريابی بهترين تلاش نام دارند که فقط کوتاهترين مسير را با توجه به يک پارامتر(پهنای باند يا تعداد پرش يا هزينه) انتخاب می کند.لذا تمام ترافيک ها به کوتاهترين مسير, مسيريابی می شوند,حتی اگر مسيرهای ديگری نیز وجود داشته باشند,مادامی که کوتاهترين مسير نباشند مورد استفاده قرار نمی گيرند.

مسئله ديگر اين است که در مسيريابی بهترين تلاش وقتی که مسير بهتری يافت شود,ترافيک به آن مسير جديد منتقل می شود حتی اگر آن مسير نيز نيازهای کيفيت سرويس آن ترافيک را تامين کند.اين امر بدليل چنين شاخص هايي موجب ناپايداری در مسيريابی می شود.

مسيريابی مبتنی بر کيفيت سرويس با رفع اين معايب بايد ترافيک را به گونه ای مسيريابی کند که بتواند ميزان گذردهی کلی شبکه را به حداکثر برساند.



مهندسي ترافيك

روش‌هايي مانند سرويس‌هاي تفكيك شده و سرويس‌هاي يكپارچه فقط در بار ترافيكي بالا تأثير محسوسي روي ترافيك ايجاد مي‌كنند و در بار ترافيكي پايين عملاً هيچ تفاوتي بين آنها و سرويس Best Effort وجود ندارد.

بنابراين در وحلة اول و قبل از استفاده از هركدام از اين مكانيزم‌ها بايد با پيكربندي و تنظيم صحيح پارامترهاي شبكه جلوي تراكم بسته‌ها را گرفت. البته هيچكدام از اين دو به تنهايي كافي نمي‌باشد بلكه اين دو مكمل يكديگر هستند. بايد تا جاي ممكن از بروز تراكم بسته‌ها جلوگيري كرد و در صورت بروز تراكم نيز بايد مكانيزم‌هاي مناسب جهت كنترل جريان بسته‌ها تعبيه شده‌باشد.

تراكم بسته‌ها ممكن است به علت عدم دسترسي به منابع يا در نتيجه توزيع نامتعادل بار روي شبكه بوجود آيد. در حالت اول تنها راه حل ارتقاء تجهيزات يا افزايش ميزان پهناي‌باند است. در حالت دوم بعضي قسمت‌هاي شبكه متحمل بار سنگيني مي‌شوند در صورتي‌كه بعضي قسمت‌هاي ديگر بار خيلي سبكي دارند.

اين مشكل ممكن است در نتيجه استفاده از پروتكل‌هاي مسيريابي پويا مانند RIP، OSPF يا IS-IS بوجود آيد چون اين پروتكل‌ها نزديكترين مسير را براي فرستادن بسته‌ها انتخاب مي‌كنند. در نتيجه هميشته كوتاهترين مسيرها بين دو نقطه پرترافيك همواره داراي بار سنگين ترافيكي هستند درحاليكه بقية مسيرها داراي بار سبكتري مي‌باشند.

در شبكه‌هاي كوچك مدير شبكه ممكن است بتواند جدول‌هاي مسيريابي را با توجه به بار شبكه دستي تنظيم كند ولي اين كار براي شبكه‌هاي بزرگ تقريباً غيرممكن است. مهندسي ترافيك فرايند تنظيم ترافيك است بگونه‌اي كه جلوي تراكم ناشي از توزيع نامتوازن بسته‌ها گرفته شود. Constraint Based Routing يك ابزار مفيد براي خودكار كردن اين فرايند مي‌باشد.

در اين روش براي انتخاب بهترين مسير فقط توپولوژي شبكه در نظر گرفته نمي‌شود بلكه وضعيت منابع، وضعيت خطوط ارتباطي، محدوديت‌هاي موجود براي جريان بسته‌ها و سياست‌هاي ديگري كه توسط مدير شبكه تعيين شده در نظر گرفته مي‌شود. بنابراين در اين روش ممكن است يك مسير طولاني بهتر از يك مسير كوتاه تشخيص داده شود و در نتيجه ترافيك بطور متوازن روي شبكه توزيع شود.

اين روش علي‌رغم مزاياي ذكر شده داراي معايبي نيز مي‌باشد كه در زير آمده است:
  • - ميزان ارتباط و تبادل اطلاعات بين مسيرياب‌ها را افزايش مي‌دهد.
  • - اندازه جدول مسيريابي را افزايش مي‌دهد.
  • - انتخاب مسيرهاي طولاني منجر به استفاده بيشتر از منابع مي‌گردد.
  • - فرايند به روز آوردن جدول‌هاي مسيريابي مشكل است.
در پروتكل های link-state كه به آنها پروتكل های shortest path first نيز گفته می شود ، هر روتر سه جدول جداگانه را ايجاد می نمايد . يكی از اين جداول وضعيت همسايگانی را كه مستقيما" به آن متصل شده اند در خود نگهداری می نمايد . در جدول ديگر ، توپولوژی تمامی شبكه نگهداری می گردد و از جدول سوم برای نگهداری اطلاعات روتينگ استفاده می شود .

روترهای link-state نسبت به پروتكل های روتينگ distance-vector دارای اطلاعات بيشتری در ارتباط با شبكه و ارتباطات بين شبكه ای می باشند. پروتكل های link-state اطلاعات بهنگام خود را برای ساير روترهای موجود در شبكه ارسال می نمايند (وضعيت لينك) .



تعریف OSPF

OSPF ( برگرفته شده از Open Shortest Path First ) يك پروتكل روتينگ IP است كه دارای تمامی ويژگی های يك پروتكل link-state است .پروتكل فوق ، يك پروتكل روتينگ استاندارد باز است كه توسط مجموعه ای از توليدكنندگان شبكه از جمله شركت سيسكو ايجاد شده است . در صورتی كه در يك شبكه از روترهائی استفاده می گردد كه تمامی آنها متعلق به شركت سيسكو نمی باشند ، نمی توان از پروتكل EIGRP استفاده كرد .

در چنين مواردی می توان از گزينه هائی ديگر نظير RIP ، RIPv2 و يا OSPF استفاده نمود . در صورتی كه ابعاد يك شبكه بسيار بزرك باشد ، تنها گزينه موجود پروتكل OSPF و يا استفاده از route redistribution است ( يك سرويس ترجمه بين پروتكل های روتينگ ) . OSPF ، با استفاده از الگوريتم Dijkstra كار می كند . در ابتدا ، اولين درخت كوتاهترين مسير ايجاد می گردد و در ادامه جدول روتينگ از طريق بهترين مسيرها توزيع می گردد .

اين پروتكل دارای سرعت همگرائی بالائی است ( شايد به اندازه سرعت همگرائی EIGRP نباشد ) و از چندين مسير با cost يكسان به مقصد مشابه حمايت می نمايد . برخلاف EIGRP ، پروتكل OSPF صرفا" از روتينگ IP حمايت می نمايد .

نتيجه گيري:

تمامی شواهد موجود نشان دهنده اين واقعيت است كه پروتكل OSPF يك پروتكل سريع ، قابل توسعه و مستحكم است كه می توان از آن در هزاران شبكه عملياتی استفاده كرد . OSPF بگونه ای طراحی شده است كه بتواند از شبكه های سلسله مراتبی حمايت نمايد .

با بكارگيری ويژگی فوق می توان ارتباطات بين شبكه ای بزرگ را به چندين شبكه كوچكتر كه به آنها ناحيه گفته می شود ، تقسيم نمود . بكارگيری پتانسيل فوق مزايای متعددی را به دنبال خواهد داشت :
  • كاهش اضافه عمليات روتينگ
  • افزايش سرعت همگرائی
  • محدود كردن بی ثباتی شبكه در يك ناحيه و عدم اشاعه آن به ساير نواحی شبكه
برگرفته از سایت njavan
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#26
حالا میخواهیم به بررسی پروتکل OSPF (کانفیگ کردنش ) بپردازیم.

عدد 1 که بعد از OSPF استفاده شده است. مثل IGRP یا EIGRP ، که شرح داده شد، AS Number نیست و در اینجا Process ID نام دارد. برعکس AS number در پراسس ID لزومی ندارد که در دو روتر ها یکسان باشد تا دو روتر با هم همسایه شوند و برای یکدیگر آپدیت بفرستند. بعبارت ساده تر یکسان نبودنش در دو روتر اختلالی ایجاد نمیکنه و مهمنیست اسم پروسه چی باشه ولی بنظر من همه رو یکسان بزنید.

اگر در روتر دستور زیر رو تایپ کنیم خروجی زیر رو میبینیم :

کد:
Router(config)#router ospf ?
<1-65535> Process ID


Process ID از عداد 1 تا 65535 میتونه باشه

یه قسمت دیگه هم داریم به اسم area

مثلا میتونید شیراز رو یک Area در نظر بگیرید تهران هم یک area

OSPF در چند Area




يکی از تفاوت های بارز اين پروتکل با پروتکل های Distance Vector اختصاص و تفکيک ناحيه ها توسط Area است. در واقع Topology Database هر ناحيه منحصر به خود بوده و بار CPU و Memory روتر ها را کمتر ميشود و هر autonomous به تعدادی ناحيه تبديل ميشود.
کافیه برای هر روتر تو شبکه به این صورت تعریف کنیم.

کد:
Enable
Config Terminal
Router Ospf 10



واسه تعریف کردن network ها در area 0 باید به این صورت عمل کنید.

کد:
net 192.168.10.0 0.0.0.255 area 0



subnet mask که تعریف کردیم اینجا معکسشو نوشتیم به همین راحتی !
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#27
در درس بعدی که میخوام اموزش بدم مربوط به vlan هست که دیدم سایت persiandatanetwork بسیار عالی ای مبحث اموزش دادن

توضیحات میزارم بعد خودم سناریو میزارم :


استفاده از سوئيچ هاي سيسكو در سازمان هاي مختلف امري عادي شده است و معمولا سازمان هاي بزرگ ترجيح مي دهند با تهيه سوئيچ هاي لايه دو و سه شبكه هاي كامپيوتري خود را ساختار يافته نموده و لايه بندي را در آن رعايت كنند. در اين نوشتار به مبحث VLANمي پردازم.

VLAN چيست ؟
VLAN همانطور كه از نام آن پيداست شبكه LAN مجازي است كه Broadcast Domain اصلي سوئيچ را كه بصورت يك VLAN وجود دارد (VLAN1) را به چندين Broadcast Domain ديگر مي شكند. به دليل اينكه سوئيچ ها قادر به برقراري ارتباط وLearn كردن از هم هستند لذا چندين پورت از سوئيچ ديگر مي تواند عضو VLAN سوئيچ ما باشد بدون اينكه Broadcast را به سوئيچ ها يا VLAN هاي ديگر منتقل كند. معمولا VLAN براي شبكه هاي بزرگ با ترافيك بالا كاربرد دارد. قبل از اينكه به نحوه تنظيم VLAN بپردازم نكاتي را كه بايد قبل از اين تنظيمات بدانيد در چند بيان مي كنم.
- VLAN در واقع يك Broadcast Domain مي باشد كه توسط سوئيچ ايجاد مي شود.
- براي تنظيم VLAN مدير شبكه ابتدا بايد VLAN را ايجاد كند و سپس پورت هاي سوئيچ را به آن مرتبط سازد.
- همه سوئيچ هاي سيسكو داراي يك VLAN بصورت پيش فرض هستند.
- در هر VLAN پورتي به نام Trunk تعريف مي شود كه قادر است ترافيك هاVLAN را به خارج يا داخل هدايت كند. اين پورت از پروتكل ISL يا 802.11q براي اين كار استفاده مي كند. با كلامي ديگر اين پورت بين چندين VLAN مشترك است و ترافيك كليه آن ها را به سوئيچ يا روتر انتقال مي دهد.
- براي ارتباط چندين VLAN از سوئيچ لايه 3 يا روتر استفاده مي شود.
حال در اينجا نحوه ايجاد VLANرا توضيح مي دهم. براي اينكه مطلب را ملموس تر بيان كرده باشم به طرح يك سناريو پرداخته و سپس دستورات مورد نياز را مي آورد.
سناريو : مي خواهم دو VLAN به شماره هاي 5 و 10 ايجاد كنيم و هدف بعدي من قراردادن پورت هاي 2 و 3 در VLAN5 و پورت هاي 4 و5 و 6در VLAN10 خواهد بود. نام VLAN5 را Marketing و نام VLAN10 را Human Resource مي گذارم. همانطور كه در بالا اشاره كردم ابتدا VLAN هاي مورد نياز را مي سازم.
کد:
Router>
Router> Enable



در اينجا كلمه عبور را وارد مي كنيم و به مد تنظيمات مي رويم.

کد:
Router# config terminal
Router (config)#
Router(cinfug)#vlan 5
Router(config-vlan)#name marketing
Router(config-vlan)#exit
Router(config)#
Router(config)#vlan 10
Router(config-vlan)name Human Resource
Router(config-vlan)#exit



تاكنون vlan هاي 5 و 10 را ساختم. حال نوبت اين است كه به هر يك از آن ها پورت هاي مورد نظرم را مرتبط كنم. براي اين كار بايد به Interface رفته و دستورات زير را وارد كنم :


کد:
Router(config)# interface fastethernet 0/2
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan5
Router(config-if)#exit
Router(config)#interface fastethernet 0/3
Router(config-if)#switch mode access
Router(config-if)#switchport access vlan 5
Router(config-if)#exit
Router(config)#interface fastethernet 0/4
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan10
Router(config-if)#exit
Router(config)#interface fastethernet 0/5
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan10
Router(config-if)#exit

Router(config)#interface fastethernet 0/6
Router(config-if)#switchport mode access
Router(config-if)#switchport access vlan10
Router(config-if)#exit




نكته : درصورتيكه چندين پورت سوئيچ را به يك VLAN مي خواهيد مرتبط سازيد مي توانيد از دستور interface range fastethernet 0/5-10 استفاده كنيد و نياز به تايپ مجدد هريك از پورت ها بطور مجزا نيست. در اين دستور پورت هاي پنج تا ده سوئيچ به يك VLAN تخصيص داده مي شوند. همچنين براي ديدن وضعيت پورت ها و VLAN ها از دستور Router(config)#show vlan اساتفاده كنيد.

فراموش نكنيد پس از انجام تنظيمات ، Running-config را در startup-config كپي كنيد و يا اينكه از دستور Write استفاده كنيد. پس از انجام اين تنظيمات بايد بدانيد در حال حاضر تنها پورت هاي 2 و 3 قادر به ارتباط برقرار كردن با يكديگر هستند و همچنين مشابه آن براي پورت هاي 4 و 5 و 6 صدق مي كند. اگر تمايل داريد بطور مثال پورت هاي دو و چهار با يكديگر تبادل بسته اطلاعاتي داشته باشند بايد از پورت ترانك و روتر استفاده كنيد. در مورد پورت ترانك و نحوه تنظيم آن در نوشتار بعدي خواهم پرداخت.
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#28
در این قسمت میخواهیم با هم چند شبکه vlan ایجاد کنیم.

حالا میخواهیم فرض کنیم.

یک شرکت به ما دادن حاوی 3 تا قسمت هست.

1.مدیران شرکت

2.کارمند ها

3.حسابداری

این شبکه از قبل کانفیگ شده حالا ما میخواهیم اینها رو از هم جدا کنیم.

سیستم حسابداری 2 تا پی سی داره کارمندها هم 2 تا و مدیران شرکت هم 2 تا پی سی دارن

حالا قسمت حسابداری و کارمندها و مدیران رو میخواهیم با یک سوئیچ از هم جدا کنیم.

تصویر :




وارد سوئیچ میشیم.


اول دستور

کد:
enable
config t




رو تایپ میکنیم.

حالا میخواهیم یک vlan ایجاد کنیم vlan 1 روی همه سوئیچ ها بصورت پیش فرض هست و حذف هم نمیشه .
ما یک vlan به شماره 5 ایجاد میکنیم.

حالا vlan 5 رو تایپ میکنید و enter میزنید.

حالا میخواهیم یک نام هم برای vlan 5 ایجاد کنیم.

نام رو modiran-sherkat میزاریم و به vlan 5 اختصاص میدیم.

بعد از اینکه name دادیم به این صورت :

کد:
name modiran-sherkat




دستور

exit رو تایپ میکنیم و سپس یک vlan دیگه ایجاد میکنیم.

vlan 6 رو تایپ کنید.

کد:
name karmandha




و سپس exit رو تایپ کنید.

vlan 7 رو تایپ کنید.

name رو hesabdari بدید به این صورت

name hesabdari

و سپس exit رو تایپ کنید.

خوب حالا 3 تا vlan ایجاد کردیم.

حالا میخواهیم وارد اینترفیس سوئیچ شویم و واسشون تعریف کنیم کدوم پی سی به کدوم vlan ارتباط داره

دستور


دستور وارد اینترفیس fastethernet 0/1 میشم
دستور

کد:
int fa 0/1

دستوری که گفتم تایپ کنید.

کد:
switchport mode access




حالا میخوایهم به vlan 5 ارتباطش بدیم.

فقط کافیه این دستور رو تایپ کنید.

کد:
switchport ACcess vlan 5




سپس دستور exit رو تایپ کنید و اینتر بزنید.

واسه fastethernet 0/2 هم به این صورت تنظیم میکنیم.

int fa 0/2

و سپس

switchport mode access

و با دستور

switchport access vlan 5

پورت 0/2 رو عضو vlan 5 قرار دادیم

exit رو تایپ کنید.

و سپس vlan 6

کد:
int fa 0/3

switchport mode access

switchport access vlan 6

exit


سپس
کد:
int fa 0/4

switchport mode access

switchport access vlan 6

exit






خوب vlan 6 هم تموم کردیم حالا سپس میرسیم به vlan 7

کد:
int fa 0/5

switchport mode access

switchport access vlan 7

exit

سپس

کد:
int fa 0/6

switchport mode access

switchport access vlan 6


به همین راحتی قسمت مدیرها کارمندها و حسابداری رو توسط سوئیچ از هم جدا کردیم.

دانلود کلیپ اموزشی :


اموزش Vlan Ccna
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#29
How to configure Trunking between VLANs with 802.1q?
در این فصل شما رو میخوام با مبحث vlan قسمت trunk اشنا کنم .
در واقع اگر بخواهیم 2 تا سوئیچ رو با هم اتصال بدیم میام از trunk استفاده میکنم.



اتصالات trunk را بين دستگاه هاي زير مي توان ايجاد نمود :


·دو سوئيچ

·يک سوئيچ و يک روتر

·يک سوئيچ و يک NIC متعلق به يک سرور که توانايي برقرار اتصال trunk را داشته باشد.


دو پروتکل مسئول عمل trunking عبارتند از :
کد:
Cisco
ISL
IEEE
802.1Q


پروتوکل 802.1 q يک استاندارد عمومي بوده و مي توان آن را بر روي
تمامي دستگاه هاي لايه 2 که از Ethernet استفاده مي نمايند پياده نمود . پروتوکل
ISL را مي توان بر روي تمامي پروتوکل هاي لايه 2 متفاوت
مورد استفاده قرار داد .دليل اين کار هم اين است که فريم اصلي به صورت کامل در داخل
يک فريم ديگر قرار داده شده و فريم اصلي دچار هيچ تغييري نخواهد شد .
پروتوکل

کد:
802.1 dot1q

را مي توان فقط در پروتوکل هاي Ethernet و Token Ring پياده نمود .
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ
#30
خوب حالا میخواهیم 5 تا پی سی با 5 نت مختلف رو به 2 سوئیچ و یک روتر متصل کنیم.
عکسی از سناریو شبکه :

گام اول برای سوئیچ Switch0 (یا همان سوئیچ اول ) در تصویر بالا نگاه کنید متوجه میشید.
خوب 3 تا vlan ساختم به نام های parsicoders و pxr.ir و اموزش گاه
دستورات :
کد:
Enable
Configure Terminal
Vlan 10
Name Parsicoders
exit
Vlan 20
Name Pxr.ir
exit
Vlan 30
Name Amouzesh
exit
خوب حالا با دستور Show Vlan وضعیت Vlan ها رو چک میکنیم.
وقتی تایپ میکنیم نتیجه زیر رو میبینیم :
کد پی‌اچ‌پی:
Switch>Show VlanVLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/1Fa0/2Fa0/3Fa0/4
                                                Fa0
/5Fa0/6Fa0/7Fa0/8
                                                Fa0
/9Fa0/10Fa0/11Fa0/12
                                                Fa0
/13Fa0/14Fa0/15Fa0/16
                                                Fa0
/17Fa0/18Fa0/19Fa0/20
                                                Fa0
/21Fa0/22Fa0/23Fa0/24
                                                Gig1
/1Gig1/2
10   Parsicoders                      active    
20   Pxr
.ir                           active    
30   Amouzesh                         active    
1002 fddi
-default                     act/unsup 
1003 token
-ring-default               act/unsup 
1004 fddinet
-default                  act/unsup 
1005 trnet
-default                    act/unsup 
حالا میخواهیم به هر کدوم از پی سی ها یک Vlan اختصاص بدیم.
البته در پست قبلی توضیحات داده بودم بازم دستورات رو میزارم تا اشتباه نکید.
کد:
Enable
interface fAstEthernet 0/1
switchport mode access
switchport access vlan 10
exitEnable
interface fAstEthernet 0/2
switchport mode access
switchport access vlan 20
exitEnable
interface fAstEthernet 0/3
switchport mode access
switchport access vlan 30
exit
در عکس توجه کنید میبینید که یکی از پورت ها به شماره 0/4 رو به روتر وصل کردیم در این جا باید از Trunk استفاده کنیم.
به این صورت :
کد:
Enable
Configure Terminal
INterface fastEthernet 0/4
Switchport mode trunk
Exit
حالا چطور سوئیچ رو به روتر معرفی کنیم؟
باید واسه سوئیچ اول یک ای پی ادرس اختصاص بدیم و یک گیت وی به این صورت :
کد:
int vlan 1
ip add 192.168.1.2 255.255.255.0
no shut
ip default-gateway 192.168.1.1
دستور بعد
کد:
enable
configure terminal
interface fastEthernet 0/0
no shut
exit
حالا چطوری 3 تا vlan که ساختیم به روتر معرفی کنیم .
در روتر اول fast ethernet 0/0 رو فعال کنید.
کد:
enable
config t
int fa 0/0
exit
vlan 1 اگر یادتون باشه روی سوئیچ ای پی پیش فرض 192.168.1.1 داده بودیم واسه vlan 1 به این صورت استفاده میکنیم.
کد:
encapsulation dot1Q 1 Native
ip add 192.168.1.1 255.255.255.0
exit
در واقع با دستور interface fastethernet 0/0.10 یک sub interface تعریف کردیم .
اطلاعات بیشتر :
توجه کنید که شماره SubInterface ها به صورت 10 و20 تعیین شده است که با شماره VLAN ها همخوانی ندارد . به یاد داشته باشید ، لزومی بر یکسان بودن این دو شماره با هم وجود ندارد . زیرا که شماره SubInterface ها فقط برای اشاره به همان Subinterface مورد استفاده قرار می گیرد و کاربرد دیگری ندارد .
همچنین در مواقعی که یک Static route را ایجاد کرده ایم ولی قصد ارسال ترافیک از یک Subinterface خاص داریم ، بعد از مشخص کردن نوع و شماره Interface یک عدد “.” گذاشته و سپس شماره Subinterface را می آوریم . برای مثال :
fastethernet0/0.20
encapsulation dot1Q 10
دستور Encapsulation را برای مشخص کردن نوع اتصالات Trunck بکار میرود و بعد از آن نیز شماره VLAN مربوطه را باید آورد . در هنگام نوشتن شماره VLAN باید دقت داشته باشیم که شماره مورد نظر را بطور صحیح و بر حسب شماره هایی که در روی vlan سوئیچ مشخص شه تایپ شود.
بقیه دستورات :

کد:
encapsulation dot1Q 10
vlan 10 رو معرفی کردیم.
حالا باید ip هم اضافه کنید.
دستور:
کد:
ip address 192.168.10.1 255.255.255.0
vlan 10 یک پی سی بهش اتصال داده بودیم gateway ان 192.168.10.1 بود subnet mask هم 255.255.255.0 بود و زیر شاخه vlan 10 بود.
همین الان vlan 10 به روتر معرفی کردیم.
حالا واسه vlan 20 دیگه دستورات پشت سر هم مینویسم توضیحات هم که دادم. واسه vlan 30 هم مینویسم :
دستورات :
کد:
Router(config-subif)#encapsulation dot1Q 20
Router(config-subif)#ip add 192.168.20.1 255.255.255.0
Router(config-subif)#exitRouter(config-subif)#int fa 0/0.30
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip add 192.168.30.1 255.255.255.0
Router(config-subif)#exit
گروه دور همی پارسی کدرز
https://t.me/joinchat/GxVRww3ykLynHFsdCvb7eg
پاسخ


موضوعات مشابه ...
موضوع نویسنده پاسخ بازدید آخرین ارسال
  دانلود کتاب CCNA Security 210-260 Official Cert Guide rezakian13 0 147 12-14-2017، 04:49 PM
آخرین ارسال: rezakian13
  جزوه جامع آموزش CCNA FarazNetwork.ir 1 6,649 12-14-2014، 02:56 AM
آخرین ارسال: ASILTASH
  دانلود رایگان فیلم های آموزشی CCNA به زبان فارسی FarazNetwork.ir 1 3,206 06-17-2014، 11:56 AM
آخرین ارسال: FarazNetwork.ir
Video دانلود رایگان فیلم های آموزشی CCNA Wireless , CWNA به زبان فارسی FarazNetwork.ir 0 4,237 10-20-2013، 12:19 PM
آخرین ارسال: FarazNetwork.ir
  دانلود رایگان فیلم های آموزشی CCNA Voice به زبان فارسی FarazNetwork.ir 0 5,513 10-20-2013، 12:17 PM
آخرین ارسال: FarazNetwork.ir
  دانلود رایگان فیلم های آموزشی CCNA Security به زبان فارسی FarazNetwork.ir 0 5,216 10-20-2013، 12:15 PM
آخرین ارسال: FarazNetwork.ir

پرش به انجمن:


کاربران در حال بازدید این موضوع: 1 مهمان
This forum uses Lukasz Tkacz MyBB addons.